Important Notice: Dynamics CRM Online ACS will be Deprecated

CRM/Dynamics365 Outlook Client Issue & Fix
October 29, 2017
2017 Microsoft Dynamics GP Year End
December 7, 2017

Important Notice: Dynamics CRM Online ACS will be Deprecated

Young Women Travel Together Concept

Recently Microsoft sent a notice to Dynamics System Administrators their Dynamics CRM AppFabric Access Control Service (ACS) service being deprecated after December 31, 2017  This service was commonly used with 3rd party or custom applications authenticate and access Dynamics CRM.

Why you should care: 

If you have applications using this ACS service and you update to Microsoft Dynamics CRM Online 2016 Update 1 (v8.1.1) or Microsoft Dynamics 365 (v8.2) this service will no longer work. Any client side component SDK (Microsft.Xrm.SDK.DLL) version 8.0 or lower should be updated to the latest version.

Some applications that may be commonly used include users with older Microsoft Dynamics CRM Outlook clients, Plugin Registration Tools from older versions of Microsoft Dynamics CRM (v8.0 or older) and older versions of some popular tools, XrmToolBox and MSCRMToolKit.

Summit Group Software is working with customers we know would be impacted. However, if you have any questions, please reach out via our Customer Portal or email us at info@sumitgroupsoftware.com.

Below are some of the specific services and versions that may need to be updated within your instance. Per Microsoft’s 365blog:

Area

 

 

 

 

Peak Portals

Action to be taken by Customers on  Dynamics CRM

Ver 8.0 & Below

 

 

 

Update to Peak Portal 3.0

Action to be taken by Customers on  Dynamics CRM/Dynamics 365

Version 8.1 or 8.2

 

 

Update to Peak Portal 3.0

Custom .Net application that is using older Microsoft.XRM.SDK.DLL  – If Microsoft.Xrm.SDK.DLL is 8.0 or older, use the SDK Client as suggested in the Team Blog If Microsoft.Xrm.SDK.DLL is 8.0 or older, use the SDK Client as suggested in the Team Blog
3rd Party Product that is interacting with Dynamics CRM If Microsoft.Xrm.SDK.DLL is 8.0 or older, teach out to 3rd Party Product Support If Microsoft.Xrm.SDK.DLL is 8.0 or older, teach out to 3rd Party Product Support
ADX V7.X Use the SDK Client as suggested in the Team Blog Use the SDK Client as suggested in the Team Blog
Customers on older version of USD (< 2.1) Use Latest USD 2.2or Use the SDK Client as suggested in the Team Blog Use Latest USD 2.2
Dynamics Connector (v8.0 or older) Use the SDK Client as suggested in the Team Blog Use Latest SDK and apply the fix using the Team Blog
Email Router (V8.0 or older) Use the SDK Client as suggested in the Team Blog Update to latest Email Router (on SDK 8.2)
Report Authoring Extension (v8.0 or older) Use the SDK Client as suggested in the Team Blog Update to the latest Report Authoring Extension
Developer Toolkit (v8.0 or older) Use the SDK Client as suggested in the Team Blog Update to the latest developer toolkit

 

Customer Portal